This article will walk you through the basic workflow of setting up your Archicad model, exporting with the cove.tool plugin, and visualizing your model on the App's Daylight and Energy analysis.

New updates for the Archicad plugin (v.1.1.3):

  1. Smarter classification of model geometry elements.

  2. Added geometry export categories: Below grade walls, Outdoor floor objects, Furniture, and Spandrels.

  3. Improved workflow for mixed-use building type exports.

  4. Ability to group select and classify & un-classify geometry.

  5. Compatible with ArchiCAD 24 & 25.

Before We Begin

Make sure to have Archicad 24 or 25 software installed. Both the Windows version and OSX version can be downloaded here.

To install them, the folder as a whole can be placed anywhere on the system, and then you have two options to install.

  1. In Archicad go to Options>Addon-Manager>Add, or

  2. Copy/Paste the folder in the default addon folder location C:\Program Files\GRAPHISOFT\ARCHICAD 24\Add-Ons on windows, Applications\\GRAPHISOFT\ARCHICAD 24\Add-Ons on OSX.

The cove.tool plugin will appear under the windows>palettes dropdown from the top toolbar and maybe at the bottom of the list, as shown in the image below.

Note for Mac Users: One can unblock this version by going to System Preferences > System & Preferences > General OR System Preferences > Security & Privacy > General

WRITTEN TUTORIAL

ArchiCAD uses a classification method specific to each model object to organize the metadata for each model.

Step 1 - Login and Create a Project

A cove.tool project is required to use the ArchiCAD plug-in. Begin by logging into cove.tool online then use the "start a new project" button. Complete the first two pages of the project setup before going back to ArchiCAD. Set up steps include adding details like Project name, location, and building type and clicking on the save & continue button. On the second page, Geometry, you will see the 3D Mode button will be greyed out until geometry is uploaded. To export geometry, go to ArchiCAD and begin the project setup for export following the steps below.

Step 2 - Open the project in ArchiCAD

The following steps will walk through the process for opening the plug-in palette, and subsequent steps to prepare your model for export. The final result will look similar to the image below. Properly classified objects will be color-coded in the cove.tool view filter and unclassified objects are colored red. Once exported, the resulting EUI breakdown is presented in the cove.tool palette as seen below.


Step 3 - Open the palette and login

To access the cove.tool plugin, open the palette by going to
Window > Palettes > cove.tool. Users will need to log in to cove.tool through the software plugin using the same username and password as your cove.tool login online.

Step 4 - Setting up the geometry for cove.tool

The cove.tool palette walks through step-by-step instructions to connect the geometry to the web application.

a. Select Project: Choose your project via the Select Project button. This will open a window with your project list. Scroll to find your cove.tool project. Note that the list is in alphabetical order and can be searched by typing.


b. Classify Model: Automatically categorizes building elements into 11 different cove.tool categories based on the position attribute of the element. The categories are Roofs, Floors, Exterior Walls, Interior Walls, Windows, Skylights, Shading Devices, Spandrels, Furniture, Below Grade Walls, and Outdoor Floors. This can take a few seconds depending on the complexity of the project. Some elements may not be classified if the plugin did not identify any geometry with the correct position ID and properties.

c. Create cove.tool view: Creates a graphic override on the existing 3D view based on the element classification. Visually inspect the objects and classify any missing objects to their proper assignment.

Note: Sub-elements of Curtainwalls (Spandrels) in Archicad currently are not overlaid with a graphics override.

Step 5 - Visually inspect classified building elements

Make sure to simplify the geometry selection and only classify the building elements that impact the thermal envelope. The cove.tool window is docked within the 3D visualization toolbar located under Window > Toolbar > 3DVisualisation.

Classification Overview

Users can access this information for each object by selecting the object or objects and accessing the Object Selection Settings and properties.

  • Right-click dropdown or toolbar icon in the top right of the screen. Navigate to the classifications and properties sections to find the cove.tool - v#.## classification.

  • Users can check/uncheck the box to turn on/off cove.tool classification, and click on the arrow to the right to open up a dropdown list with the different cove tool categories.

  • Click on the layer for the object selected to assign the classification to the Archicad object.
    The cove.tool plugin adds a classification specific to the cove.tool layers that can classify any object to the appropriate layers as described in the previous section. Below is a .gif of the classification process.

This is helpful to check if the drawing objects have been classified in the correct categories. As a reminder, cove.tool needs 4 required layers, exterior walls, roofs, floors, and windows to export the geometry.

Step 6 - Export

After inspecting the geometry and ensuring all objects are properly classified, use the EXPORT button to export the geometry to the cove.tool web application to the previously assigned project. If an error occurs return to the top of this article to review that all of the essential layers are classified and provided for export.

Upon exporting successfully, the dialog box displays a quick breakdown of the energy use in the building. The feedback loop for EUI breakdown provides an iterative workflow for testing design options and their impact on the whole building EUI.

Step 7 - Go to cove.tool in your browser and refresh the geometry page

Navigate to the cove.tool geometry page in a web browser and refresh the page to see the geometry import. Avoid exporting stairs as they may be read as separate floors and generate an error. Once everything looks good, click continue to save the geometry export and move forward to the daylight page.

Happy Modeling!


Related Articles:

Did this answer your question?