This article covers the steps users need to install the cove.tool geometry export plugins. Cove.tool Plugins are free of charge and can be found on their respective Extension Library Platforms Below. Tutorials and other help resources for plugins can be found in cove.tool's App Store. 

Autodesk Revit (v. 2017-2021)

Download the lastest Revit Plugin. The plugin is compatible with Revit 2017 and later. There are two installation methods. Either method will not impact your capabilities but are available based on user preference. 

  • Note: If a user has previously downloaded the Revit plugin with the Install Manually process (before November 2019), they will not be able to download a different version of the plugin until the previous plugin files have been deleted. [Not necessary for different versions of Revit.] To overwrite the previous plugin version, locate the folder "C:\ProgramData\Autodesk\Revit\Addins\YYYY" and delete files "CoveRevit (Folder)" & "CoveRevit.addin". Note that this file path might be hidden in your folders, to see it go to the View tab and check Show Hidden items. After you have successfully deleted these files, install the updated versions with your preferred download method. 
  • If you're using Windows, uninstalling the previous plugin can be done by opening "add and remove programs" in the search bar and searching for cove.tool. Select it and check what version is currently installed on your computer. You should be seeing 2.3.0, if not uninstall this version and try rerunning the latest .msi install file from the cove.tool App Store. If you have a very secure network, you may need to unblock the .msi file before running the install process. To do that, right-click on the file in your download folder, open properties, and at the bottom, check an option titled "unblock". Click OK, and run the install. see images below.

(Method 1) Install Automatically 

  1. Download and install the MSI file here. Have Revit during the install process.
  2. "Unblock" the file by right-clicking and opening the properties folder. If you do not see a security section, then proceed to run the .MSI file (image 1 below).
  3. Run the MSI, to install the plugin locally (image 2). If an administrator is required to install new applications onto your machine, contact one, and share these instructions.
  4. Launch Revit. A Security Panel will appear (image 3) upon opening Revit. Select the Always Load option to enable the cove.tool plugin inside Revit. 

(Method 2 - location sensitive) Install Manually

Reminder, if you previously installed the plugin with the .msi file, run the file again and select the Uninstall option. Make sure all previous cove.tool addins have been uninstalled and Revit is closed while installing the manual plugin.

  1. Download the zip folder "CoveRevit_v2.3.0.zip" from this dropbox link.
  2. Before unzipping the contents of the “CoveRevit v2.3.0.zip” file, right-click on the file and open the Properties window. A Security section at the bottom of the window may appear with the option to "Unblock". Make sure to check this box.
  3. Unzip “CoveRevit v2.3.0.zip” and add the contents to folder location C:\ProgramData\Autodesk\Revit\Addins\YYYY. Note that this file path might be hidden in your folders, to see it go to View tab in your folder menu and check Show Hidden items.
  4. Restart Revit. A Security Panel will appear (image 2) upon opening Revit. Select the Always Load option to enable the cove.tool plugin inside Revit. 

After the step, most users should be good to go.

INSTALL ERROR MESSAGES

1. (Error msg) External Tool Failure: LaunchPanel failed

If you have opened your project in Revit and still do not see the cove.tool plugin in your Add-in tabs or you receive an error message like the one below, then you did not "Unblock" the file while installing, and your computer's firewall is preventing the plugin to initiate enable tool-bar command or export-script sequence. Repeat the install process with an unblocked file and restart Revit.

2. (Error msg) Command Failure for External Command: Contact the provider

Seeing this error message below means your Revit plugin is out-of-date and needs to be reinstalled with the latest version. The plugins require annual code-signing certification and this must be routinely updated for security precautions. Find the latest Revit plugin on the cove.tool app store.

If the plugin is still experiencing issues, please contact the livechat support team inside the app. 

SketchUp (v. 2016 - 2020)

Download the SketchUp Plugin from the Cove.tool Plugin Page. The plugin is compatible with SketchUp 2016 through 2020.  NOTE: If you have an older version of the plugin, make sure to first uninstall the plugin, before attempting to install the latest version. To uninstall an existing plugin;

  • Launch any SketchUp project. Under the Window tab, locate Extension Manager. Inside the Extension Manager window, navigate to the Manage tab, and below should be listed your previous "Cove.tool SketchUp Extension" plugin. Select Uninstall to delete this version. Proceed to install the latest plugin.

To install,

  1. Download the .RBZ file for the cove.tool app store.
  2. Extract the zip folder, and place the file in the following folder locations.
    > From PC Users, add the “CoveTool_SketchUpExtension_2.0.0.rbz” file to C:\Users\%USERNAME%\AppData\Roaming\SketchUp\SketchUp YYYY\SketchUp\Plugins.
    > For Mac Users, add the download .rbz file to folder location:
    ~/Library/ApplicationSupport/SketchUp YYYY/SketchUp/Plugins 
  3. Launch SketchUp. Under the Windows tab, locate Extension Manager. At the bottom of the Extension Manager window, will be a bright red button labeled Install Extension. Click it and a file search window will open. Locate the .RBZ file from the previous folder location. (image below)
  4. The Extension Manager will then add cove.tool SketchUp Extention to the application list. Make sure the file is enabled in the 2nd tab, Manage.
  5. Once the plugin has been successfully installed, a new toolbar should appear (image 3). Selecting the extensions tab>cove.tool should prompt the toolbar to launch. The cove.tool toolbar is 'floating' by default, so if you do not see it right away make sure to check your other screens, or minimize SketchUp to prompt the toolbar. (image below).

Rhino/Grasshopper

Download the Rhino/Grasshopper Plugin. The plugin is compatible with Rhino 5 and Rhino 6 with grasshopper extensions.  

If you are using Rhino 5, make sure you have installed GhPython and Grasshopper for Rhino 5.0 (64-bit), to continue with the plugin process. Version previous to Rhino v.5.0 are not compatible with the cove.tool plugin.

Locate the downloaded .zip file, and extract contents to a familiar location. In Rhino, launch grasshopper and select the .gh file inside to unzipped folder to loas the plugin definition. The most recent version of the plugin published is titled "covetool_daylight_energy_v2.0.2" or higher. Once the script load, users should the grasshopper definition like the image below.

  • NOTE: As you start using the grasshopper plugin for geometry export, always create a clone of the definition to your unique project folder. Reusing the same file for every project may result in overwriting previous projects and general chaos.

Related Articles:

Did this answer your question?