Archicad provides a BIM workflow for designers to start exporting their geometry to cove.tool. This article will walk through the basic workflow of setting up your model, exporting with the Archicad plugin, and seeing your geometry in cove.tool. Here is the link to the Archicad video tutorial that goes through the steps outlined below.

Note for Mac Users: One can unblock this version by going to System Preferences > System & Preferences > General OR System Preferences > Security & Privacy > General

Users can now export geometry with the Archicad 25 plugin v1.0.1 and follow the same process as other software - create a project, classify building elements into cove tool categories, export into the web application, and see the results.

Before We Begin

The Geometry Plugins are BIM extensions that make exporting building geometry, a quick and accurate process. By automating 90% of the workflow, cove.tool gives the time it takes to set up and run a simulation, back to the designer. Make sure you have the most recent plugin version to use this feature.

What Geometry is required for a cove.tool project?

Cove.tool runs various types of building performance simulations. Each analysis type requires its own set of inputs and standards which are used to output accurate results and diagrams. The simulations which require geometry values need them in the following categories: Roofs, Floors, Exterior Walls, Windows, Building Height, Skylights (optional), Interior Walls (optional), and Shading devices (optional). If your BIM model contains these objects, then you have the components required to make an accurate analysis model for cove.tool. Having these elements is only half the battle. The other half is making sure that those objects are compatible with the automation and export process required of the plugin tool.

The next section will cover all the components required to assign the appropriate model properties and useful tools and tips for setting up these elements for an error-free export.

PLUGIN INSTALL

Make sure to have the Archicad 25 software installed. Both the Windows version and OSX version can be downloaded here.

They are named cove_archicad24_1.0.0-2-osx and cove_archicad24_1.0.0-2-windows. To install them, the folder as a whole can be placed anywhere on the system, and then you have two options to install.

  1. In Archicad go to Options>Addon-Manager>Add, or

  2. Copy/Paste the folder in the default addon folder location C:\Program Files\GRAPHISOFT\ARCHICAD 24\Add-Ons on windows, Applications\\GRAPHISOFT\ARCHICAD 24\Add-Ons on OSX.

The cove.tool plugin will appear under the windows>palettes dropdown from the top toolbar and may be at the bottom of the list, as shown in the image below.

WRITTEN TUTORIAL

First Export to cove.tool

Archicad uses a classification method specific to each model object to organize the metadata for each model. The cove.tool plugin adds a classification specific to the cove.tool layers that can classify any object to the appropriate layers as described in the previous section. Below is a summary of the classification process followed by the steps to prepare and export your project geometry.

Classification Overview

Users can access this information for each object by selecting the object or objects and accessing the settings and properties through the right-click dropdown or toolbar icon in the top right of the screen. Navigate to the classifications and properties sections to find the cove.tool - v#.## classification. Users can check/uncheck the box to turn on/off cove.tool classification, and use the dropdown option to assign to a cove.tool layer.

Step 1 - Login and Create a Project

A cove.tool project is required to use the Archicad plug-in. Login into cove.tool online and start a new project. Set up the project with the proper details of name, location, and building type and click on the save & continue button. The 3D Mode button will be greyed out until geometry is uploaded. Once the geometry is uploaded, select 3D Mode. To export geometry, go to Archicad and begin the project setup for export following the steps below.

Step 2 - Open the project in Archicad

The following steps will walk through the process for opening the plug-in palette, and subsequent steps to prepare your model for export. The final result will look similar to the image below. Properly classified objects will be color-coded in the cove.tool view filter and unclassified objects are colored red. Once exported, the resulting EUI breakdown is presented in the cove.tool palette as seen below.

Step 3 - Open the palette and login

Open the design project you wish to analyze in Archicad. To access the cove.tool plugin, open the palette by going to Window>Palettes>cove.tool. Users will need to login to cove.tool through the software plugin using the same username and password as your cove.tool login online.

Step 4 - Setting up the geometry for cove.tool

The cove.tool palette walks through step-by-step instructions to connect the geometry to the web application and is as easy as steps A, B, & C. Follow the instructions by clicking the button on each screen of the palette walkthrough. Below are the steps in sequence.

a. Select Project: start by selecting the project from a drop-down menu. Click SELECT to complete and move to the next step.

b. Classify Model: Automatically categorizes building elements into cove.tool elements. This can take a few seconds depending on the complexity of the project.

c. Create cove.tool view: Creates a graphic override on the existing 3D view based on the element classification. Visually inspect the objects and classify any missing objects to their proper assignment.

Step 5 - Visually inspect classified building elements

Make sure to simplify the geometry selection and only classify the building elements that impact the thermal envelope. The cove.tool window is docked within the 3D visualization toolbar located under Window>Toolbar>3DVisualisation.

The cove.tool view provides custom graphic settings for all the objects. Color assignment for each layer can be seen in the pop-up window for graphic override combinations, which located at the bottom right of the view.

This is helpful to check if the drawing objects have been classified in the correct categories. As a reminder, cove.tool needs exterior walls, roofs, floors, and windows to export the geometry. Objects can be reclassified manually: select the element> right-click to open Object Selection Settings > Classification and Properties > Classifications > Check cove.tool v1.0.1 as presented earlier. Click on the arrow to the right to open up a dropdown list with the different cove tool categories. Click on the layer for the object selected to assign the classification to the Archicad object.

Step 6 - Export

After inspecting the geometry and ensuring all objects are properly classified, use the EXPORT button to export the geometry to the cove.tool web application to the previously assigned project. If an error occurs return to the top of this article to review that all of the essential layers are classified and provided for export.

Upon exporting successfully, the dialog box displays a quick breakdown of the energy use in the building. The feedback loop for EUI breakdown provides an iterative workflow for testing design options and their impact on the whole building EUI.

Step 7 - Go to cove.tool in your browser and refresh the geometry page

Navigate to the cove.tool geometry page in a web browser and refresh the page to see the geometry import. Avoid exporting stairs as they may be read as separate floors and generate an error. Once everything looks good, click continue to save the geometry export and move forward to the daylight page.

Happy Modeling!

Did this answer your question?